Topic: Take Off Problems


I am in Sydney, Australia and bought an AR. Drone today but am having some problems with it.

When I try to take off, the drone will lift about 10cm off the ground and then veer off in a random direction.

I am current running firmware version 1.4.6 with FreeFlight 1.6

I have tried rolling back the firmware to 1.3.3, and have tried using the DroneControl iPhone app.

Nothing I have tried has lead to a successful take off and getting into a hover. Currently I have only tested inside.


Re: Take Off Problems

Have your tapped the reset button on the underside, then unplug the battery, rest the AR Drone on a flat level surface and plug it back in.

The lower button resets the auto trim built into the AR Drone.

Check out  for more AR Drone info and helpful content.
AR Drone Wiki for more information -

Re: Take Off Problems

I went through that and a number of other troubleshooting steps, but was unable to get it going.

I returned it last night and got a replacement, my new one is working fine.