Topic: How to reinstall firmware

Hi all

I've been reading a lot of post about the firmware update not working and causing ARDrones to go wrong.

I thought I would write a quick guide that should help.

The ARDrone will check what firmware version it has and not let you reinstall the same or lower version,  Even if the firmware upgrade went wrong.

You can trick the ARDrone into reinstalling the firmware by editing two files on the ARDrone via telnet.

Download putty from here http://the.earth.li/~sgtatham/putty/lat … /putty.exe

Connect the battery to the ARDrone and wait for the green LEDs as normal.

Press the “unpair” button on the bottom of the ARDrone.

Connect to the ARDrones wireless ad-hoc network on your Windows computer.

Open putty.

Enter “192.168.1.1” in the box labeled “Host Name (or IP adress)”.

Under “Protocol” select “Telnet”.

Click “Open” and you should get a terminal window open up.

Enter “cat update/version.txt firmware/version.txt”.

It should show

1.1.3

1.1.3

Enter “echo 1.0.3 > update/version.txt” and “echo 1.0.3 > firmware/version.txt”

Again enter “cat update/version.txt firmware/version.txt”.

It should now show

1.0.3

1.0.3


You can now reinstall the firmware via the ftp method or reconnect using a iphone and it should reinstall it when launching the free flight app.

Hope this helps

Matt

Re: How to reinstall firmware

For those on OSX you can do the same in Terminal, just open it up and 'Telnet open 192.168.1.1' and continue from the 'Enter “cat update/version.txt firmware/version.txt”' in the above great post.

Great write up Matt.

Check out  http://www.ardrone-flyers.com  for more AR Drone info and helpful content.
AR Drone Wiki for more information - http://www.ardrone-flyers.com/wiki/

Re: How to reinstall firmware

There are several telnet clients for iPhone / iPAd this would save the unpair - connect to computer stage

Re: How to reinstall firmware

I'm trying to update my firmware, but keep getting the error:

Update process failed
FLASH_KO

I've tried doing the PC method and iphone method, both failing.

I tried what you said with putty and successfully changed the version.txt files, but that had no effect.  Is there any way to manually update the firmware within terminal?

Thanks!

Re: How to reinstall firmware

Thanks a lot for this, i used this solution after updating to 1.5 / 1.3.3 which turns your drone in to a brick. Basically if you update to 1.3.3 the motor leds stay on read, you can connect to the drone and see the video feed, but you get a MOTOR EMERGENCY error.

Following the above, along with deleteing the 1.5 iPhone APP, i restoring 1.4 from my iTunes backup, i was then able to reinstall 1.1.3 back on it.

I'm trying to do another upgrade to 1.5 but it seems as if there is a major bug in it, so unless you want a lot of wasted time dont bother with 1.5 for now sad