1 (edited by Lcheater 2012-02-25 7:09:27 pm)

Topic: BMW E46 Drivers front speakers not working with MKI9200 installation

Hi,

I have just fitted a MKI9200 hands free kit to my 2001 BMW 3 series (e46).

I am using a standard BMW round-pin business stereo and used a SOT-060 ISP adapter cable to connect it all up.

Everything works fine apart from I get very little sound from the front right speakers (tweeter near the mirror, the medium sized speaker in the middle and the bigger speaker at the bottom of the door).

This is the same whether I am using the hands free kit or the radio on the stereo. If I unplug the SOT-060 cable and plug my stereo back into the original wiring loom the sound in those two speakers comes back instantly.

I have checked and double checked all the connectors and everything is fine.

What can it be?

Re: BMW E46 Drivers front speakers not working with MKI9200 installation

Hi,

Your observations would assume faulty wiring loom or loose connections/pins, double check connections while music is playing, if possible a new wiring loom will need to be tested to identify the cause of the problem.


Kind Regards.

Parrot Advisor UK 3
Parrot UK & Ireland
E mail: http://www.parrot.com/uk/support/hotline/
08444 722 360

Re: BMW E46 Drivers front speakers not working with MKI9200 installation

If all wiring appears to be intact, open Blue Box & check that no connector pins have pushed back.

Re: BMW E46 Drivers front speakers not working with MKI9200 installation

Thanks for the replies so far.

I have replaced the SOT-060 cable today and it has made no difference at all. I also fitted a replacement standard stereo (because the on/off button was faulty and the antenna plug broke off during installation of the hands free kit), so it has a new stereo (exactly the same part number, genuine BMW) and a new replacement SOT-060 cable, but no change.

Could a faulty loom between the blue box and the SOT cable cause this problem? Considering the speakers don't work even when the stereo sound (I.e radio and CD changer) are used?

Re: BMW E46 Drivers front speakers not working with MKI9200 installation

It sounds like there may be a fault with your MKi bluebox or loom pins on the right channel speaker loom (grey - grey/black cables), please return to your place of purchase so this can be investigated and if found to be faulty replaced under warranty.

Parrot UK & Ireland
E mail: http://www.parrot.com/uk/support/hotline/
08444 722 360

Re: BMW E46 Drivers front speakers not working with MKI9200 installation

I have a similar problem with my e46 (04). I installed an mki9000 today but the front passenger side speakers dont work.  The front drivers and both l&r rear speakers work.

Mine is slightly different however in that if I play the radio through the headunit it is fine, but playback of anything through the Parrot - or calls for that matter don't come out of ththe front left speakers

I bought a directly connected audio2car for bmw 17 pin lead instead of using the ISO harness - I have checked all the connectors and they seem fine and locked in place.  As its brnad new I didn't want to open up the bluebox as suggested above.  Any ideas?

Re: BMW E46 Drivers front speakers not working with MKI9200 installation

I solved my issue - I had plugged in the unika cable when I dont have steering wheel controls, this had caused the problem for some reason

All sorted  smile